"Error Code: 500 Internal Server Error"

CAC access to secure web sites for Mac OS
jim_t
Site Admin
Posts: 344
Joined: Wed Feb 23, 2011 5:10 pm

"Error Code: 500 Internal Server Error"

Post by jim_t » Tue Sep 17, 2013 8:10 am

If you are getting an error "500" when trying to access a site, there may be an issue with the Identity Preference for that site. Here are the steps to remove the ID Pref and repair any Keychain issues:

- Pull your card from the reader and quit any browsers
- Launch Keychain Access (in the /Applications/Utilities/ folder)
- Make sure that Keychains is set to "login" and Category is set to "All Items"
- In the top right of this window, enter part of the website URL in the search filter field (e.g. "mail.mil" or "army")

- In the results, find the "Identity Preference" for the site you were trying to access and delete it

- Go to the Keychain Access menu (next to the apple) and choose Keychain First Aid
- Enter you password, select Repair, then click Start
- When the Repair completes, select Verify, then click Start
(If it returns "Verification Failed", scroll up to see if there is only one red line that includes "crlcache.db". This is a known and acceptable issue.)
- Close Keychain First Aid and quit Keychain Access

At this point, you should be able to put your card in the reader, launch Safari, and access whichever sites you need. If you follow these steps, but still continue to run into problems, please contact us at support@thursby.com

Regards,

Jim Thomas
Senior Support Specialist

jschechter
Posts: 1
Joined: Sat Oct 05, 2013 12:43 am

Re: "Error Code: 500 Internal Server Error"

Post by jschechter » Sat Oct 05, 2013 12:47 am

I tried this and am still getting the error. What other ways can I fix?

jim_t
Site Admin
Posts: 344
Joined: Wed Feb 23, 2011 5:10 pm

Re: "Error Code: 500 Internal Server Error"

Post by jim_t » Mon Oct 07, 2013 8:29 am

jschechter wrote:I tried this and am still getting the error. What other ways can I fix?

jschechter,

Which site are you trying to access?

Regards,

Jim Thomas
Senior Support Specialist

anthead
Posts: 1
Joined: Sun Nov 10, 2013 5:04 pm

Re: "Error Code: 500 Internal Server Error"

Post by anthead » Sun Nov 10, 2013 5:21 pm

This did not work for me either. I have 10.9 and uninstalled/reinstalled v1.4 several times, tried both Safari and Chrome, tried deleting the DoD system/login certificates and manually adding them my self, nothing seems to work, please help!..

I could of swore this worked perfectly on Snow Leopard but ever since 10.7 I've had issues.

michaelwolfe
Posts: 319
Joined: Fri Feb 17, 2012 11:49 am

Re: "Error Code: 500 Internal Server Error"

Post by michaelwolfe » Mon Nov 18, 2013 9:26 am

anthead wrote:This did not work for me either. I have 10.9 and uninstalled/reinstalled v1.4 several times, tried both Safari and Chrome, tried deleting the DoD system/login certificates and manually adding them my self, nothing seems to work, please help!..

I could of swore this worked perfectly on Snow Leopard but ever since 10.7 I've had issues.
I apologize for the delay, have you received a new card or new certificates recently?

-Michael

dox1842
Posts: 12
Joined: Mon Dec 30, 2013 7:26 pm

Re: "Error Code: 500 Internal Server Error"

Post by dox1842 » Tue Feb 11, 2014 1:41 pm

I just recently had this problem. Its very bizarre because I checked my email this past friday and it worked perfectly. I cannot access OWA or Navy Reserve Website but I did get on NKO for a brief moment. I guess I can try again tomorrow. I really do not understand why pkard would all of a sudden quit working when I havent installed any new updates or software.

FlightManager
Posts: 1
Joined: Tue Oct 04, 2016 8:17 am

Re: "Error Code: 500 Internal Server Error"

Post by FlightManager » Tue Oct 04, 2016 8:22 am

I am now getting this error after upgrading to OS Sierra and installing PKard v1.7, KeyChain for this version of the OS has removed the Keychain First Aid, so the original fix won't work. I am able to get to most sites requiring my CAC, however, the only thing I can't get in to and get the 500 error is Outlook Web Access, anyone else?

michaelwolfe
Posts: 319
Joined: Fri Feb 17, 2012 11:49 am

Re: "Error Code: 500 Internal Server Error"

Post by michaelwolfe » Tue Oct 04, 2016 8:27 am

FlightManager,

Keychain First Aid was actually removed in a dot release of El Capitan due to a security flaw, and it appears that the Keychain is keeping its affairs in order on its own. I suggest that you remove the Identity Preference for your webmail as an existing preference may be preventing Safari from logging in, or the wrong certificate was chosen the last time you tried. This forum post contains the steps on how to remove the Identity Preferences for websites. The next time you try to log in make sure you are selecting the first DOD EMAIL certificate in the list. Alternatively, if you know the https://web-xxxxx.mail.mil address, you can always try that.


Michael

Nathan
Posts: 8
Joined: Wed Feb 22, 2017 11:56 am

Re: "Error Code: 500 Internal Server Error"

Post by Nathan » Wed Feb 22, 2017 12:46 pm

Been getting this error for about 2-3 weeks now, after having no problems. Trying to access Navy west webmail (OWA). I've got v1.7.1 and El Capitan 10.11.6. Tried deleting the identity preference via keychain access. Uninstalled PKard and reinstalled (made sure only one copy is on the Mac). Light on the card reader is good, and it recognizes my card. Don't know what happened. One of my coworkers is dealing with the same problem, another says his is working just fine...so that leads me to believe the problem isn't on the Navy side. Help??

David Mattes
Posts: 25
Joined: Fri Nov 11, 2016 11:24 am

Re: "Error Code: 500 Internal Server Error"

Post by David Mattes » Wed Feb 22, 2017 5:08 pm

Nathan,

Have you tried deleting the cookies for webmail? This can be done by going to Safari Preferences > Privacy > Manage Website Data. From this screen put ".mil" in the search box, and when mail.mil appears click on it then click remove. Once this is done please restart the Mac and try accessing webmail again. If it this persists, please try accessing East and see if it changes anything for you.

David

Post Reply