Page 1 of 2

Office 365 OWA Not Functional

Posted: Mon Feb 05, 2018 4:22 pm
by mjruss
My account was just migrated to Office 365. Since then the OWA interface in Sub Rosa has been sub-optimal. It is slow to respond to taps, there’s a banner across the top of each screen (something about an attempted security violation) that cannot be closed, and it is unable to read encrypted messages or sign outgoing messages because the S-MIME control is not running.

Has anyone else seen this, or is this just a problem on my iPad or with my account? Is there a work-around to get web mail back to Sub Rosa’s normal high level of usability please?

Re: Office 365 OWA Not Functional

Posted: Mon Feb 05, 2018 5:50 pm
by michaelwolfe
mjruss,

Our Enhanced OWA Client doesn't support Office 365 yet, but we are currently working to add this functionality into the app. Until then, you will only be able to access your email through the browser.


-Michael

Re: Office 365 OWA Not Functional

Posted: Mon Jul 16, 2018 8:18 am
by mjruss
Any updates? I am struggling with the Office 365 Web Interface right now (slow as molasses in Sub Rosa, and I can only reply to about two e-mails before I have to reset the interface and log in all over again), and could really use a fix.

I realize it’s only been five months, but hoping there might be something in the near term..?

Thanks!

Re: Office 365 OWA Not Functional

Posted: Mon Jul 16, 2018 8:51 am
by michaelwolfe
mjruss,

I have created a call in our Support database in order to better track this issue. You should see an email in the next few minutes. I will update this thread once Office 365 support is available in Sub Rosa for iOS.


-Michael

Re: Office 365 OWA Not Functional

Posted: Mon Jul 16, 2018 8:57 am
by mjruss
Thanks! I hope Microsoft’s systems don’t give you too much trouble!

Re: Office 365 OWA Not Functional

Posted: Fri Aug 10, 2018 12:32 pm
by pkiAK
Is there an update on this issue? Namely getting the enhanced OWA mode in subrosa to work with O365 webmail page?

Would love to use s/mime and other features.

Thanks

Re: Office 365 OWA Not Functional

Posted: Tue Aug 14, 2018 9:10 am
by michaelwolfe
pkiAK,

We are currently working on an update to Sub Rosa that includes support for Office 365. I will send an email from our Support Database that includes a call number, and we'll be reaching out for beta testers once there is something public.


-Michael

Re: Office 365 OWA Not Functional

Posted: Fri Oct 19, 2018 10:29 am
by Brandy2Harris
Hello are there any updates on this issue? I travel often and need access to my email on the road. I would be happy to be a beta tester if there's something in the works.

Re: Office 365 OWA Not Functional

Posted: Fri Oct 19, 2018 10:52 am
by michaelwolfe
Brandy2Harris,

We are working to roll out a beta, and I'll send you an email from our Support Database for more information.


-Michael

Re: Office 365 OWA Not Functional

Posted: Thu Jan 03, 2019 8:46 am
by fwilliams1
Is there any update on this? If the new version isn't ready for general release, can I get a copy of the beta software?