Files Not Displaying on CIFS Mount

User discussion forum for prior versions of DAVE
Forum rules
This forum is for user discussion of DAVE, and is not intended as a source of technical assistance.
Please note that only the most basic installation or configuration support will be offered by Support Specialists for legacy versions.

Files Not Displaying on CIFS Mount

Postby H4nd0 » Wed Sep 04, 2013 9:12 pm

Hi there,

If I copy files from a Windows 7 machine to our file server (Synology NAS), none of our Macs running DAVE 10 see the copied over files. We have to Apple+I to get the volume information or unmount/remount the share before the files show up. It's very annoying.

Is there anyway workaround for this?

Thanks!
H4nd0
 
Posts: 4
Joined: Wed Sep 04, 2013 9:08 pm

Re: Files Not Displaying on CIFS Mount

Postby jim » Thu Sep 05, 2013 7:58 am

H4nd0,

The issue you describe shouldn't be a problem, as DAVE v10 includes the ability to check for changes on a mounted share without having to unmount/remount. I have some questions about the situation:

- Which version of Samba is your Synology NAS running?

- Does this same issue occur if you copy a file from a Mac to the Synology, or only when you copy from a Windows machine?

- Does this same issue occur when connected to a Windows share?


Regards,

Jim Thomas
Senior Support Specialist
jim
Site Admin
 
Posts: 342
Joined: Wed Feb 23, 2011 5:10 pm

Re: Files Not Displaying on CIFS Mount

Postby H4nd0 » Mon Sep 09, 2013 3:17 am

Hi Jim,

The Macs and PC are connected to the same Windows share on the Synology.
When files are copied from Mac, the Mac sees the copied files.

SMBD
Version 3.6.9
Synology Build 3211, Apr 11 2013 17:38:39

NMBD
Version 3.6.9
Synology Build 3211, Apr 11 2013 17:38:39

Thanks,

James
H4nd0
 
Posts: 4
Joined: Wed Sep 04, 2013 9:08 pm

Re: Files Not Displaying on CIFS Mount

Postby H4nd0 » Mon Sep 09, 2013 7:45 pm

Hi there,

I upgraded to the latest DAVE 10 Build 1534 on OS-X 10.8.3.

These are the issues I'm seeing:

* Finder crashes when you try and play a video off a CIFS mounted network drive. After the crash it usually works.
* Copying files or creating directories on the file server (when copying from a Windows machine) just do not appear in Finder unless you Apple-I
* Deleting files is problematic. If you are in Windows and have a file or folder highlighted you can't delete that file or Folder. DAVE complains you do not have permissions.

TIA
H4nd0
 
Posts: 4
Joined: Wed Sep 04, 2013 9:08 pm

Re: Files Not Displaying on CIFS Mount

Postby jim » Fri Sep 13, 2013 9:23 am

James,

I'll address your three concerns in order:

1. Finder crash : We haven't had any reports of this issue. If the problem is reproducible, I would recommend contacting us at support@thursby.com for some targeted tracing instructions.

2. File listings refresh: This is another problem that should not be occurring, but I will admit that we don't test against every implementation of Samba. I would recommend testing against a Windows share and let us know if the same thing happens.

3. Delete permissions: If a file is listed as 'open' on the server, you will not be able to delete it. This will all depend on how the server sees a file as 'open'. You should be able to determine on the server whether a file is still listed as open or not.

Regards,

Jim Thomas
Senior Support Specialist
jim
Site Admin
 
Posts: 342
Joined: Wed Feb 23, 2011 5:10 pm


Return to Legacy DAVE Versions

Who is online

Users browsing this forum: No registered users and 1 guest