admitmac and mountain lion

User discussion forum for prior versions of ADmitMac
Post Reply
hackztor
Posts: 6
Joined: Tue Jan 08, 2013 12:15 pm

admitmac and mountain lion

Post by hackztor » Thu Apr 18, 2013 10:27 pm

Mountain Lion does not seem to like the scripts that are included in admitmac 7.01. I had to do
xattr -l
xattr -d com.apple.quarantine

for each of the scripts in the pkg to make it install.

jim_t
Site Admin
Posts: 344
Joined: Wed Feb 23, 2011 5:10 pm

Re: admitmac and mountain lion

Post by jim_t » Fri Apr 19, 2013 7:57 am

hackztor,

This is the first report we've had of this kind of problem. Were you getting an error message when attempting to install?

------------------------------
Jim Thomas
Senior Support Specialist

hackztor
Posts: 6
Joined: Tue Jan 08, 2013 12:15 pm

Re: admitmac and mountain lion

Post by hackztor » Fri Apr 19, 2013 5:13 pm

Yes when running the custom pkg file with mountain lion:
First when launching pkg I get admitmac is damaged and cant be opened. you should move it to the trash. TexEdit created this file.

I then run sudo xattr -r -d com.apple.quarantine on the pkg and it will then get past that message and install.

If you dont use -r for the recursive, then you get similiar messages for preflight,post_common,InstallLicense,UninstallProperties and unmount in addition to license file missing.

4/19/13 2:41:38.000 PM kernel[0]: exec of /Users/irts/Desktop/ADmitMac copy.pkg/Contents/Resources/preflight denied since it was quarantined by TextEdit and created without user consent, qtn-flags was 0x00000006

hackztor
Posts: 6
Joined: Tue Jan 08, 2013 12:15 pm

Re: admitmac and mountain lion

Post by hackztor » Fri Apr 19, 2013 5:14 pm

Oh and we never noticed these before when we did ml because we use a script to install and configure product and it seemed happy, but started noticing it when we use deploy studio after imaging to install the product.

jim_t
Site Admin
Posts: 344
Joined: Wed Feb 23, 2011 5:10 pm

Re: admitmac and mountain lion

Post by jim_t » Fri Apr 19, 2013 6:53 pm

hackztor,

It sounds like you are using a script with an ADmitMac Deployment created installer pkg. If that is the case, I would recommend contacting us directly at support@thursby.com with the following information:
  1. The version of ADmitMac you have installed. You can find this by launching the ADmitMac Network Utility (/Applications/Utilities/) and clicking the Versions tab.
  2. The Serial Number in use. You can find this on the Info tab of the ADmitMac Network Utility.
  3. The version of OS X that was used to create the installer pkg.
  4. A copy of the ADmitMac Deployment settings file used to create the file.
I'll go over the information as soon as that comes in and find out what's going on. As soon as there is any information about the nature of the problem and its resolution, I'll update this forum post.
------------------------------
Jim Thomas
Senior Support Specialist

Post Reply