ActiveX control needs to be enabled

CAC access to secure web sites for Android devices using the Thursby Sub Rosa™ app and Thursby branded card readers.
Post Reply
nkite66043
Posts: 3
Joined: Wed Jul 08, 2015 2:44 pm

ActiveX control needs to be enabled

Post by nkite66043 » Wed Jul 08, 2015 3:06 pm

If I select Internet Explorer as my User Agent, when logging onto OWA I get the message "The ActiveX control needs to be enabled in Internet Explorer for Outlook Web App to work correctly. Click here to sign out, enable your ActiveX control, and then sign in to Outlook Web App.

If I change the User Agent to Google Chrome for Windows and use Fips 140-2 Mode (off or on) I get into OWA however when the page stops initially loading I get the following error" Your request couldn't be completed. This may have occurred for security reasons or because your session timed out."

I have tried the secure reset and deleting the cache but keep getting the error. I was able to use PKARD Reader (IOS) or Safari 8 (IOS) and had successful results.

NK

carl
Site Admin
Posts: 178
Joined: Wed Feb 23, 2011 5:04 pm
Location: Arlington, Texas
Contact:

Re: ActiveX control needs to be enabled

Post by carl » Wed Jul 08, 2015 3:38 pm

You definitely don't want to use the IE User Agent. IE communicates with OWA in ways that no other browser can, and when you choose that user agent, the server expects that type of communication.

Try the default user agent first. If that doesn't work, let us know what problems you're having.

nkite66043
Posts: 3
Joined: Wed Jul 08, 2015 2:44 pm

Re: ActiveX control needs to be enabled

Post by nkite66043 » Thu Jul 09, 2015 7:44 am

I originally did start with the default user and that didn't work. I read through the forums and figured out how to try different settings. I am now trying the web.mail.mil with a dual persona and seem to be having some connectivity issues as well.

michaelwolfe
Posts: 320
Joined: Fri Feb 17, 2012 11:49 am

Re: ActiveX control needs to be enabled

Post by michaelwolfe » Thu Jul 09, 2015 7:52 am

nkite66043,

The default settings for PKard Reader should be able to get you into your webmail, and because you are a Dual Persona user, you will need to make sure you are selecting the PIV Authentication certificate.

I would also verify that you are allowing sites to create cookies. Some sites won't allow you to authenticate if a cookie cannot be created.

Post Reply